JrIDE and Cartridges

Hardware questions and modifications

JrIDE and Cartridges

Postby Tempest » Fri Oct 11, 2013 3:45 pm

I thought I had cartridges working with my jrIDE but when I try to run my Activision cartridges or Imagic cartridges they don't work. I select Cartridge or Basic from the boot menu but it always goes to Basic. The IBM cartridges appear to work however. I have the latest BIOS update so I'm not sure what's wrong. Occasionally I'll get an E0ERROR but not all the time, I'm not sure what the significance of that is.
Omne ignotum pro magnifico

--- AtariProtos.com ---
The color of infinity inside an empty glass
Tempest
 
Posts: 308
Joined: Thu Jan 14, 2010 5:43 pm

Re: JrIDE and Cartridges

Postby Brutman » Fri Oct 11, 2013 9:09 pm

Are you sure you have the latest BIOS? November 12 2012 is the latest.

When it boots is it going to Cartridge BASIC or Cassette BASIC? If you have anything other than the game cartridges loaded, that is a user error.

Lastly, I think that E0 is an addressing problem. Make sure everything is seated correctly and clean.
Brutman
Site Admin
 
Posts: 930
Joined: Sat Jun 21, 2008 5:03 pm

Re: JrIDE and Cartridges

Postby Tempest » Sat Oct 12, 2013 9:06 am

Ok I got everything but River Raid working, but I'm not sure if that has anything to do with the system or the cart. I hear a click like it's going to cart and all I get is a black screen. The cart is new and I know it worked before so I'm not sure what's up. Anyone else got a River Raid cart and jrIDE they can try? Maybe it does something 'weird'?
Omne ignotum pro magnifico

--- AtariProtos.com ---
The color of infinity inside an empty glass
Tempest
 
Posts: 308
Joined: Thu Jan 14, 2010 5:43 pm

Re: JrIDE and Cartridges

Postby Brutman » Sat Oct 12, 2013 9:14 am

For the benefit of others who will read this later, what did you do that changed things?

I have RiverRaid but my machine is not setup. I might be able to test it over the weekend.


Mike
Brutman
Site Admin
 
Posts: 930
Joined: Sat Jun 21, 2008 5:03 pm

Re: JrIDE and Cartridges

Postby Tempest » Sat Oct 12, 2013 11:08 am

I cleaned the cartridge slot and made sure the cartridges were all clean as well. I wonder if my cartridge slot isn't getting a little loose? Can you use game carts in either slot?
Omne ignotum pro magnifico

--- AtariProtos.com ---
The color of infinity inside an empty glass
Tempest
 
Posts: 308
Joined: Thu Jan 14, 2010 5:43 pm

Re: JrIDE and Cartridges

Postby Trixter » Thu Oct 17, 2013 8:38 am

I've never seen a cart that required a specific slot.

The latest BIOS does solve cartridge booting, so glad you updated your jrIDE. As for River Raid, it requires a joystick, so without one installed it won't start up. Additionally, I seem to recall that a single joystick had to be in a specific port (can't remember if it was the left or right port) so swap ports if that doesn't work.

I tend to have two sticks connected at all times so I usually never see these problems. However, this bit me once; I had a stick connected with a sticky button that would occasionally stay depressed. This borks most joystick detection routines, including the built-in diags (they hang), so double-check your stick before trying River Raid.
You're all insane and trying to steal my magic bag!
Trixter
 
Posts: 507
Joined: Mon Sep 01, 2008 12:00 am
Location: Illinois, USA

Re: JrIDE and Cartridges

Postby Tempest » Wed Oct 23, 2013 10:37 am

Maybe it was the joystick that was the issue? I'll have to check which port it's plugged into. I'm always picking the wrong one.
Omne ignotum pro magnifico

--- AtariProtos.com ---
The color of infinity inside an empty glass
Tempest
 
Posts: 308
Joined: Thu Jan 14, 2010 5:43 pm


Return to PCjr Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

cron