Page 1 of 1

Win 3.1 misbehaving

PostPosted: Fri Apr 21, 2017 6:03 pm
by Vorticon
I recently built a 486 PC based on the AMD 486DX2 66mhz CPU and a collection of parts off of Ebay, including a Trident 1MB VLB video card, generic multi-IO controller card, Sound Blaster 16, 3.5" and 5.25" floppies and a Digital Research 52X CDROM. I have 48megs of RAM on board.
I installed DOS 6 on it and it works perfectly fine and all the games I tried with it worked as expected. However, when I installed Win 3.1, the installation when fine, but subsequently all I get is the splash screen then back to the C: prompt when I try to run it. The weird part is that it works fine for a few minutes when the system has been shut down for a while, then it either freezes or I get weird errors. Again no issues with DOS.
What I have tried, all to no avail:
- reverted to the standard VGA driver for Windows
- replaced the VLB video card with an OAK 512K SVGA card
- Eliminated all unnecessary drivers from the config.sys and autoexec.bat files
- Put a heat sink and fan on the CPU (normally should not be needed for a 486DX2)
- Replaced all the SIMM RAM with a single 4meg SIMM
- Replaced the power supply with a new beefier one (300W)

Any thoughts as to how to approach this issue? Could it be the CPU or the motherboard? If it was either, wouldn't DOS be affected?

Re: Win 3.1 misbehaving

PostPosted: Sat Apr 22, 2017 3:54 am
by bhtooefr
That sounds like it could be heat-related, or potentially bad capacitors.

What are the weird errors, though?

Also, being a 486, it's likely new enough to run Memtest86+.

Re: Win 3.1 misbehaving

PostPosted: Wed Apr 26, 2017 9:51 pm
by Vorticon
Turned out the CPU was the issue. I replaced it with an AMD 486 DX4-100 while I was at it and now Windows is starting up fine.
I also added a slave CF IDE drive to complement the vintage Conner 425meg HD as well as for easy transfers between the 486 system and my modern PC.
I'm going to install TDL on it :)

Re: Win 3.1 misbehaving

PostPosted: Thu Apr 27, 2017 9:28 am
by Trixter
Please do! If you want a lot more games more appropriate for a 486, first grab ftp://ftp.oldskool.org/pub/misc/temp/tdl_pcjr.zip and make sure it's working, then replace the files\ directory and the *.IDX files out of this: ftp://ftp.oldskool.org/pub/misc/temp/386_test.zip It contains 386-appropriate games which should behave better on your 486.

ftp://ftp.oldskool.org/pub/misc/temp/tdl_pcjr.zip has the most recent code so please use those .EXE and .INI files with 386_test. And if something goes wrong, or you have suggestions, please comment over in this thread: viewtopic.php?f=7&t=619

Re: Win 3.1 misbehaving

PostPosted: Fri Apr 28, 2017 4:07 am
by Vorticon
Thanks! I'll set it up tomorrow and let you know if I run into any issues.