JR-IDE LBA Too Old

Hardware questions and modifications

JR-IDE LBA Too Old

Postby Chuckphd53 » Thu Aug 16, 2018 4:32 pm

Tried my Jr-IDE tonight, got a message HD to old LBA (paraphasing)

I ordered a Kingspec 8G DOM, and of course Ebay sends a Zheino brand and it gave the ‘too old for LBA’ message
so I guess we can add the Zheino 8Gb to the ‘does not work list”

Update:
Tried a SEAGATE ST3160215ACE 160G drive
Found the drive, did fdisk ok
tried format, got a ‘Divide Overflow’ error

Also tried a Toshiba HDD2183-C 8.455G drive
did not find the drive






chuck
(PCJR/JR-IDE-512DOM,TandyMod,V20-10Chip,BiDir,LPT2,3FlopBrd,
USBEmulator,ZIP100,PS2Keybrd,MouseSysMouse,InternalSwitcherPS)
Chuckphd53
 
Posts: 180
Joined: Sun May 13, 2018 9:15 am
Location: Florida, USA

Re: JR-IDE LBA Too Old

Postby Brutman » Sun Aug 19, 2018 1:33 pm

A better BIOS would handle both CHS and LBA addressing. What I stole/hacked together is pretty crude. Still, I'm surprised than any DOM is not handling LBA.

There is a "Universal BIOS" for XT-IDE that claims to support the jrIDE. Do you feel lucky?

http://www.xtideuniversalbios.org/

I've never tried it. Seems a bit too heavy-weight, but it might be what you need.
Brutman
Site Admin
 
Posts: 1030
Joined: Sat Jun 21, 2008 5:03 pm

Re: JR-IDE LBA Too Old

Postby Chuckphd53 » Sun Aug 19, 2018 1:44 pm

I have a coupl more DOMs coming, for now I need to get comfortable with w working JrIDE board.

I will hook the Zheino DOM up againa and try, but it said ‘too old, LBA not supported”
Have a Hyperdisk 512M and 2G coming, lets see if these work....
(PCJR/JR-IDE-512DOM,TandyMod,V20-10Chip,BiDir,LPT2,3FlopBrd,
USBEmulator,ZIP100,PS2Keybrd,MouseSysMouse,InternalSwitcherPS)
Chuckphd53
 
Posts: 180
Joined: Sun May 13, 2018 9:15 am
Location: Florida, USA

Re: JR-IDE LBA Too Old

Postby Hargle » Thu Aug 23, 2018 6:52 pm

This issue is likely due to corrupt data being returned when the module is returning data in the identify drive function. The DOMs absolutely support LBA, but when the data is examined by the BIOS, the bit that claims support in the ID data isn't set. Aside from retries and adding delay functions to the BIOS, there isn't much that can be done here- this is more of a hardware issue, not in the IDEjr per se, but by some modules not adhering to timing specifications.
Hargle
 
Posts: 147
Joined: Wed Apr 27, 2011 3:53 pm

Re: JR-IDE LBA Too Old

Postby Chuckphd53 » Fri Aug 24, 2018 4:47 am

Got it, makes sense...
(PCJR/JR-IDE-512DOM,TandyMod,V20-10Chip,BiDir,LPT2,3FlopBrd,
USBEmulator,ZIP100,PS2Keybrd,MouseSysMouse,InternalSwitcherPS)
Chuckphd53
 
Posts: 180
Joined: Sun May 13, 2018 9:15 am
Location: Florida, USA

Re: JR-IDE LBA Too Old

Postby Chuckphd53 » Thu Aug 30, 2018 2:22 pm

OK Rcvd the 512M and 2G Hyperdisk DOM’s

AS EXPECTED THE 512M seems to work, but after loading system files when I press ESC for the menu, the
menu starts to display but hesitates for a few seconds,then finishes and allows me to press C.


I also tried the 2G, but it said the drive was too old, and would not recognize it.
seems to see it attached but,like the Zhenico DOM does not like the size I guess....l
(PCJR/JR-IDE-512DOM,TandyMod,V20-10Chip,BiDir,LPT2,3FlopBrd,
USBEmulator,ZIP100,PS2Keybrd,MouseSysMouse,InternalSwitcherPS)
Chuckphd53
 
Posts: 180
Joined: Sun May 13, 2018 9:15 am
Location: Florida, USA

Re: JR-IDE LBA Too Old

Postby kotto7877 » Wed Jun 12, 2019 8:12 pm

Chuckphd53 wrote:Tried my Jr-IDE tonight, got a message HD to old LBA (paraphasing)

I ordered a Kingspec 8G DOM, and of course Ebay sends a Zheino brand and it gave the ‘too old for LBA’ message
so I guess we can add the Zheino 8Gb to the ‘does not work list”

chuck


Gah!! This just happened to me -- a year after you! I ordered a Kingspec 8GB DOM from an ebay seller, waited for the slow boat to bring it over the ocean, only to receive it today and find that it is Zheino brand and gives the "too old for LBA" message. BAD SELLER! Need to place a warning out there that seller "zhonghainuo2010" is the fraud who is listing Kingspec DOMs but shipping Zheino DOMs that don't work with the jr-IDE.

Very bad form.

Sigh... I'm having so much bad luck with this.

1. First I tried an IDE CF adapter that I'd already owned. LBA too old.
2. Then I tried an IDE SD adapter that I picked up quick with amazon prime shipping. I have not been able to get it to boot, but I can use it as long as I boot with a floppy.
3. Then I ordered a Kingspec 8GB DOM from amazon, only to realize upon receipt that it is a 44-pin DOM rather than 40-pin. Returned it.
4. Then I ordered a Kingspec 8GB 40-pin DOM from ebay, to receive a stupid Zheino brand today instead of Kingspec. I'll be starting an ebay case about this in a few minutes.

Now... I wonder if I'm just doing something wrong with my IDE SD adapter. Has anyone had this problem, where they can use an IDE device with jr-IDE but cannot boot from it? I'm wondering if I missed something that's commonly known, something like a patch that is required for it to work. IIRC sys.com on C: worked, but attempts to boot just have it sit there with a blank screen.

I am now having trouble finding this legendary Kingspec 8GB 40-pin DOM... it wasn't on Amazon, only the 44-pin variety. I'm starting to wonder if I should reorder a 44-pin DOM and also buy a 44-pin-to-40-pin adapter. I had rejected that previously because it would be messier than hooking up a 40-pin DOM, but in the absence of a functional 40-pin DOM and no luck booting from SD, I might have to turn to this.
kotto7877
 
Posts: 5
Joined: Sun Mar 10, 2019 11:23 am

Re: JR-IDE LBA Too Old

Postby Chuckphd53 » Thu Jun 13, 2019 7:42 am

Hey I'm still around, ugh....work is kicking my butt this year....hope to get back on here soon..

good to know that the DOM's may be fake.....this would explain alot...

I'll revisit this soon 'I Hope!'

Chuck
(PCJR/JR-IDE-512DOM,TandyMod,V20-10Chip,BiDir,LPT2,3FlopBrd,
USBEmulator,ZIP100,PS2Keybrd,MouseSysMouse,InternalSwitcherPS)
Chuckphd53
 
Posts: 180
Joined: Sun May 13, 2018 9:15 am
Location: Florida, USA

Re: JR-IDE LBA Too Old

Postby Roscoe » Fri Jun 14, 2019 7:17 am

I am also having the boot problem with an SD to IDE adapter not booting.

I am using this SD adapter: https://www.amazon.com/gp/product/B07G29TZPS with a store brand 32 GB SD card from Microcenter. I am running DOS 3.3. Like kotto7877, I can only use the drive if I boot from a floppy. If I try to boot from the SD card, it will just sit there with a blank screen.

I have a single partition sized for DOS 3.3. I am planning on trying DOS 5 to see if it solves the boot issue. But work and kids are also kicking my butt right now.

I basically stopped at: Cool, my PCjr has a hard drive!

So, any solutions or suggestions would be awesome.

I do wonder if an SD based storage solution might be a good choice in the long run. Finding appropriate spinning disks or compatible DOMs or CF cards is only going to get harder as time goes on. With the SD adapter, the IDE controller is in the adapter, so once a SD to IDE adapter that works is found, the memory is just memory. I suspect that if in 5 or 10 years you need to replace the storage, it is going to be a lot easier to find a SD card.

Plus my laptop has a SD slot, so it is really easy to move data back and forth.

Now if only we can get the SD adapter to boot....
Roscoe
 
Posts: 11
Joined: Thu Mar 28, 2019 7:15 am
Location: Minneapolis, MN

Re: JR-IDE LBA Too Old

Postby kotto7877 » Fri Jun 14, 2019 8:54 am

Roscoe wrote:I am also having the boot problem with an SD to IDE adapter not booting.

I am using this SD adapter: https://www.amazon.com/gp/product/B07G29TZPS with a store brand 32 GB SD card from Microcenter. I am running DOS 3.3. Like kotto7877, I can only use the drive if I boot from a floppy. If I try to boot from the SD card, it will just sit there with a blank screen.

I have a single partition sized for DOS 3.3. I am planning on trying DOS 5 to see if it solves the boot issue. But work and kids are also kicking my butt right now.

I basically stopped at: Cool, my PCjr has a hard drive!

So, any solutions or suggestions would be awesome.

Now if only we can get the SD adapter to boot....



This is exactly the SD to IDE adapter that I bought, as well. This is the only listing on Amazon that gave a hint that it might be compatible by the description that says this:

Attention: Some of the mother board required to enable LBA mode and disable DMA transfer mode.

I just couldn't shake the feeling that maybe I needed to patch something (given comments in the past about having to patch certain versions of DOS to work on the jr). Since you have exactly the same problem as I have, it's probably not the case.

I am having fun with this, but I don't want to remain dependent on the floppy drive. I still have nightmares of floppies going bad at the worst times. On the upside, I've ordered a Gotek floppy emulator, which should make things substantially better for me in a couple of weeks or so. I have been away from retro computing for so long that I didn't even know about this Gotek floppy emulator until recently.

I had the same thoughts as you regarding the use of an SD card: easiest way to copy files to/from modern computers.
kotto7877
 
Posts: 5
Joined: Sun Mar 10, 2019 11:23 am

Next

Return to PCjr Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron