jr HOTSHOT II troubleshooting

Hardware questions and modifications

jr HOTSHOT II troubleshooting

Postby Trixter » Sun Nov 03, 2013 11:14 am

I removed a jrHOTSHOT II from a system so I could check if it had the Tandy 1000 mod (it did!) and when I replaced the jrHOTSHOT, the system acted as if it didn't have a CPU in it (the monitor turns white and emits a buzz when you turn both the monitor and PCjr on). I took the CPU off the hotshot and put in the system, booted fine. So my first guess is that I damaged the hotshot when I pulled it out.

I happen to have a second hotshot that I removed from a system a while ago, so I put that in... and the same thing happened, wouldn't boot. I then tried both hotshots in a second PCjr and same thing -- both won't boot. So my second guess is... what? I have two damaged hotshots? Those are really sturdy boards and all I did was remove them so I have a hard time believing they're both bad, but maybe that's the case... Is there something else I need to do, or is plugging them in all that is necessary?

(Before you ask, I was very careful to check throughout testing that all pins were in the socket (both cpu->hotshot and hotshot->pcjr). I also tried both 8088s and NEC V20s in the hotshot sockets.)

What do you guys think is going on?
You're all insane and trying to steal my magic bag!
Trixter
 
Posts: 508
Joined: Mon Sep 01, 2008 12:00 am
Location: Illinois, USA

Re: jr HOTSHOT II troubleshooting

Postby Trixter » Wed Nov 06, 2013 12:18 pm

Nothing? Nobody has any thoughts (even "yes, you somehow broke both of them ya moron")?
You're all insane and trying to steal my magic bag!
Trixter
 
Posts: 508
Joined: Mon Sep 01, 2008 12:00 am
Location: Illinois, USA

Re: jr HOTSHOT II troubleshooting

Postby jmetal88 » Wed Nov 06, 2013 3:37 pm

Check for bent pins maybe?
jmetal88
 
Posts: 794
Joined: Sun Jul 25, 2010 10:22 am

Re: jr HOTSHOT II troubleshooting

Postby Trixter » Wed Nov 06, 2013 6:51 pm

Double-checked that on both boards (for almost an hour), no change.

What a bummer. Anyone want a Jr HOTSHOT II card of unverifiable functionality?
You're all insane and trying to steal my magic bag!
Trixter
 
Posts: 508
Joined: Mon Sep 01, 2008 12:00 am
Location: Illinois, USA

Re: jr HOTSHOT II troubleshooting

Postby Trixter » Wed Dec 04, 2013 10:20 am

Update: Sold one to geoffdaddy and he reports it works just fine in his PCjr. So I am looking at my remaining one sideways, unsure of where the trouble is. I'll hold onto it for now, I guess.
You're all insane and trying to steal my magic bag!
Trixter
 
Posts: 508
Joined: Mon Sep 01, 2008 12:00 am
Location: Illinois, USA

Re: jr HOTSHOT II troubleshooting

Postby geoffdaddy » Thu Dec 05, 2013 2:05 pm

Trixter wrote:Update: Sold one to geoffdaddy and he reports it works just fine in his PCjr. So I am looking at my remaining one sideways, unsure of where the trouble is. I'll hold onto it for now, I guess.


In the case of my system, I had to install a socket because the CPU was soldered on (the CPU also appeared to be a 'pull' because the bottom of the CPU case had scratchmarks, although that's neither here nor there). One thing I've noticed is that the machine pin connector on the Hotshot doesn't have the most positive fit with the socket I installed despite it being a new socket (it's a regular wiper style instead of machine pin type), so I wonder if maybe your socket is just worn? Something to consider.
PCjr: 10MB RACore 01 hard drive expansion, Hotshot 640kB RAM expander, optical mouse, Xircom PE3, speech sidecar.
geoffdaddy
 
Posts: 121
Joined: Wed May 15, 2013 5:22 pm


Return to PCjr Hardware

Who is online

Users browsing this forum: No registered users and 1 guest