Page 1 of 1

Can't get my Xircom PE3-10BT to work...

PostPosted: Sat Mar 14, 2015 9:28 am
by Sharkey1331
Well, I've tried a 486 and a PC jr, and I can't get the Xircom adapter to work. I don't think its a software issue, because I've got all the same parts running in a dosbox, and I'm able to use IRCjr and IRC works.

Any ideas? Here is more info:
1) PE3TEST works, all tests pass. I have noticed, it is transmitting out with no errors- is there supposed to be anything received or showing up on the input side in this test? Both 486 and PCjr have same behavior here- which is, packets going out with no errors, but nothing coming in or seen on the network. On the PCjr, I have to run this with the NON option- my parallel adapter is not yet modded for bi-directional.
2) packet driver works, and reports back the mac address.
3) MTCPCFG is set, and reads the packetint and the hostname from the cfg file, per documentation
4) DHCP- runs, and connects to the adapter, but can't aquire an IP address. All 3 attempts time out, and it says nothing was received from the DHCP. I do see the led blink with each DHCP request going out...
5) I turned on logging, which I recall essentially said nothing was received back from DHCP. My home network is hosting a number of other devices (including this same SW in DOSBOX (Hal 9000 modded), and it all works, aquires an IP address, and it's Game ON from there...

Think I've got a bad Xircom? It reports it is OK HW wise in the PE3TEST. Think I need to do the bi-directional parallel port mod?

Jason

Re: Can't get my Xircom PE3-10BT to work...

PostPosted: Sat Mar 14, 2015 9:52 am
by jmetal88
Do you think it cold be an incompatibility with your router or whatever you're connecting to?

EDIT: Actually yeah, the bidirectional mod might help. My PE3 worked out of the box, but my parallel port had already been modded for use with my ZIP drive.

Re: Can't get my Xircom PE3-10BT to work...

PostPosted: Sat Mar 14, 2015 2:34 pm
by Brutman
Is it really reporting the MAC address? All FFs is not valid; the mac address reported should match what is printed on the device.

Your symptom sound like incoming packets are not being received.

Are you telling pe3pd to use a hardware interrupt? If so, which hardware interrupt are you using? Have you tried INT=0 to disable using a hardware interrupt, thus using polling instead?

Are you sure that your cabling is working correctly? Have you checked the wires on the adapter to make sure that none are bent and thus not contacting the Ethernet cable pins?

The bi-directional modification is not required. Do not start altering sidecars until you get it working first. Then you can do the bi-directional modification to make it faster.

Re: Can't get my Xircom PE3-10BT to work...

PostPosted: Sat Mar 14, 2015 6:24 pm
by Sharkey1331
Ok, mission accomplished! Mike was correct, it was the contacts in the Xircom. Nothin a little disassembly and prying with a guitar pick couldn't fix! :-)

Just to complete the info- it was a legit mac address= not all FF's.. I'd never used the device before, and didn't realize that in test mode, pe3test shows you stuff going out (the periods) and then RVS spaces I guess show network traffic- I never got this part before until the contacts were fixed... And, with bad contacts- the test program still showed all tests passed. Except, I got a loopback failed test once caused by a low battery (powering xircom with a battery pack until I can find an adapter), and later I found that this would happen if I did not test with the NON option (non bidirectional I think)..

Thanks again Mike for the tip about the contacts, and the great software!!! See you dudes online!