Error using rtc.com with real-time clock

Software related questions

Error using rtc.com with real-time clock

Postby Franko » Thu Oct 25, 2018 6:29 pm

After receiving and installing my new jrIDE board, I put a fresh CR2032 battery in the holder and verified the voltage (3.33v) with a multimeter.

I then started the PCjr, watched the jrIDE BIOS load with POST numbers on the alphanumeric display, and booted to DOS 3.21.

Next, I used the date and time commands to set DOS to the current date and time. When I ran rtc /r I got what appeared to be normal execution:

JR-IDE - Setting RTC Clock from DOS
Thursday October 25, 2018 - 6:14:40p

Next, I manually changed the DOS date/time, and then used rtc /d with the intention of setting DOS date/time from the real-time clock. This time I got the following:

JR-IDE - Setting DOS Clock from RTC
ERROR: Unable to update DOS time
Unknown Unknown 24, 1958 - 6:42:42p

The first couple of times I tried this, I left the jrIDE's dip switches in the default positions as received -- switches 1, 2 and 3 all off, meaning that the RTC would use IRQ7.

Noting that the Nerdly Pleasures writeup on the jrIDE recommended using IRQ2, I then changed those dip switches to off, on, off. This made no change, and I got the same error.

Any suggestions on how to fix this? Is there any other initial setup or config I need to do? Any possible issue with the DOS version?
Franko
 
Posts: 70
Joined: Wed Sep 19, 2018 9:23 am

Re: Error using rtc.com with real-time clock

Postby KenG » Fri Oct 26, 2018 9:44 am

Did you look at the date and time in DOS after setting it using the date and time commands? That error looks like you have the date set wrong in DOS.
Enhanced PCjr with a jr-IDE (1GB DOM) and a parallel port side car with a compact flash reader and backpack 1.44mb floppy attached. Tandy video mod.
KenG
 
Posts: 204
Joined: Sat Jul 16, 2016 5:36 pm
Location: Cincinnati, Ohio

Re: Error using rtc.com with real-time clock

Postby Franko » Fri Oct 26, 2018 10:33 am

Yes, if I sent the current date and time in DOS manually, they are correctly stored in DOS.

When I run "rtc /d", it has no effect on the DOS date and time.

I don't know where "Unknown Unknown 24, 1958 - 6:42:42p" is coming from when "rtc /d" is run. Those numbers are consistent regardless of how the DOS time is set at any time, and/or whether "rtc /r" was run first.

It would be interesting to query the RTC module to see if it's actually storing values after "rtc /r" is run. But I'd need more info on what function call is involved (or the memory address for the RTC data?) to cobble something together to do this.
Franko
 
Posts: 70
Joined: Wed Sep 19, 2018 9:23 am

Re: Error using rtc.com with real-time clock

Postby Trixter » Fri Oct 26, 2018 10:42 am

I checked https://www.retrotronics.org/download/j ... k-utility/ but I don't think alanh put the source there. I can disassemble it for you with a few hints, but without the original watcom source, it's going to look like a lot of data sent to/from port 70h which might not be useful.
You're all insane and trying to steal my magic bag!
Trixter
 
Posts: 589
Joined: Mon Sep 01, 2008 12:00 am
Location: Illinois, USA

Re: Error using rtc.com with real-time clock

Postby alanh » Fri Oct 26, 2018 7:29 pm

I did test the RTC before I sent it. Make sure the battery is inserted correct - positive/flat side facing outward. I can swap the board out if that isn't it.

The IRQ is only for the 'alarm' function which there is no current BIOS support for atm.

The reason the utility is failing is the RTC chip isn't responding and it's trying to tell DOS to set an invalid date/time.

The source for everything is in my SVN repository linked from the project page and here:
https://www.retrotronics.org/svn/jride/trunk/

Let me know. Email me directly if you can't get it working and I can swap out your board.
alanh
 
Posts: 303
Joined: Tue May 10, 2011 6:52 pm
Location: Atlanta, GA

Re: Error using rtc.com with real-time clock

Postby Franko » Fri Oct 26, 2018 9:36 pm

Thanks, Alan, I'll email you.
Franko
 
Posts: 70
Joined: Wed Sep 19, 2018 9:23 am


Return to PCjr Software

Who is online

Users browsing this forum: No registered users and 1 guest